Segunda y tercera actualización de WP Carousel 0.4

This post was published 9 years ago. It may be exremely outdated.

Hoy ha sido reportado en el foro un bug importante que afecta a WP Carousel 0.4.0.x y WordPress 2.8.x. El bug consiste en que la función add_theme_support no existe en versiones anteriores a WordPress 2.9 y al tratar de llamarla directamente, el script falla y no se puede activar el plugin.

Este fallo está arreglado en la versión 0.4.0.2 de WP Carousel, que en las próximas horas estará disponible en el servidor de WordPress (lo que tarde en actualizar los datos sobre la última versión, ya que ésta ya está en el repositorio), sin embargo este bug no es el único que se arregla en esta versión, sino que hay otros 4 más que no han sido reportados pero sí arreglados.

Para comenzar, se ha actualizado la traducción de WP Carousel, que ahora también traduce el texto que precede al código que se debe poner para mostrar el carrusel (antes siempre estaba en inglés, ahora la traducción española está disponible), por otro lado se ha arreglado un error en el código HTML del theme default-sidebar que consistía en que una capa (div) estaba abierta pero no se cerraba. Ahora WP Carousel y WP Main Menu son compatibles. Anteriormente no lo eran porque olvidé renombrar la variable $path, que indicaba rutas a ciertas carpetas y archivos. Realmente sólo he visto que afecta al gestor de themes, pero realmente podría afectar a muchas más cosas así que he renombrado esta variable a $wp_carousel_path, eliminado posibles repeticiones (en la próxima versión de WP Main Menu renombraré también la variable). Por último se ha arreglado un fallo en el gestor de themes que hacía que en los datos de la versión theme activado siempre se mostrase el valor 1.1, en lugar del valor correspondiente.

Disculpad la cantidad de bugs de estas versiones. Las prisas por liberarlo han acabado haciendo que no revisase bien los fallos. Al menos son fallos fáciles de arreglar y a las pocas horas ya hay una nueva versión disponible, pero disculpadme de nuevo.

Edito: He encontrado un bug más, que hacía que no se mostrase la lista desplegable para seleccionar el contenido que se debe añadir al carrusel. Este error es el único que arregla la versión 0.4.0.3.

6 Responses to Segunda y tercera actualización de WP Carousel 0.4

Ayayay, ayayay, jeje. Bueno, no pasa nada si ya están solucionados 🙂

Jaja es que es prácticamente imposible tener controladas las 3670 líneas que forman el archivo wp-carousel.php (y hay que sumarle las de los themes, con lo cual llegaríamos a 4000 líneas).

Imagina que es un texto, y que no tienes el corrector ortográfico del Word para que te revise la ortografía…

Aunque bueno, no me cuesta arreglar los bugs, lo que me cuesta es detectarlos.

Hola,

Al momento de instalar el plugin y de querer activarlo, me salen estas líneas y no me dejan usarlo:

Warning: Invalid argument supplied for foreach() in C:hosting…MI_DOMINIOwp-contentpluginswp-carouselwp-carousel.php on line 88

Cómo puedo solucionarlo?

Hola, aunque me gusta la nueva version me quede con la vieja ya que pude editarla un poco, pude cambiar la imagen y ponerla los thumbail de wp 2.9 y entres otras cosas espero que no hay problema por editar un poco su plugins.

Gracias,,,

@Practicante: Ya he visto el error y está solucionado en la cuarta actualización de WP Carousel (0.4.0.4). El problema ocurría porque en la versión 0.4.0.1 añadí ese bucle para arreglar un error pero no tuve en cuenta el caso en el que el contenido no fuese una matriz (por ejemplo, al instalar por primera vez o al desinstalar el plugin).

La solución manual es añadir antes del bucle foreach de la línea 88 el siguiente código:

<code>
if (is_array($wp_carousel_config_temp))
</code>

Con eso se comprueba que es una matriz y en caso de que así sea, se inicia el bucle.

Ya estoy subiendo la nueva versión, gracias por reportar el error 🙂 .

@cnet: Por supuesto que no hay el más mínimo problema en editar cualquier parte del plugin. Bueno, para ser sincero, creo que no se puede editar el código JS de StepCarousel por problemas de licencia, pero todo lo que he añadido yo puedes modificarlo sin problemas.

De hecho, yo tampoco voy a actualizar a la versión 0.4, ya que utilizo una mezcla entre WP Carousel 0.3 modificado y el theme especialmente modificado para no mostrar los artículos del carrusel en el index del blog.

@Sumolari

ok… dejame decirte que este plugins es el mejor en su estilo, ya que antes yo buscando conseguia pero ninguno que hiciera lo que hace esto y a demas no tan complicado (H)

Leave a Reply