WP Carousel 0.5 requiere WordPress 3.0

Beware: This post was published 7 years ago and its content may be outdated.

Al liberar WP Carousel 0.5 no revisé los requisitos mínimos en cuanto a la versión de WordPress, ya que realmente tan sólo había cambiado de lugar las funciones que ya usaba anteriormente, así que no le di la más mínima importancia. Sin embargo, WP Carousel 0.5 no es compatible con versiones anteriores a WordPress 3.0. En esta versión de WordPress añadieron un estupendo sistema que avisa a los desarrolladores cuando usamos una función obsoleta. WP Carousel 0.5 utilizaba dos funciones que estaban marcadas comos obsoletas: un parámetro de la función encargada de mostrar los enlaces de las páginas de opciones y una función que sirve para mostrar el enlace a la encuesta una única vez a los usuarios.

Para ser exactos, en cuanto a los enlaces del Panel de Administración, usaba un valor numérico para los permisos de los usuarios, en lugar del nombre del tipo de cuenta requerida. Por lo que respecta a la segunda función, se trata de una que permite asociar una pareja de índice-valor a cada usuario. El uso es muy sencillo: si el usuario que ha accedido a la página no tiene cierto valor en cierto índice (que sólo es usado por WP Carousel), se le muestra el mensaje para participar en la encuesta y se modifica el índica para que sí que tenga dicho valor (de modo que ya no volverá a ver el mensaje de la encuesta). La idea era ofrecer a los usuarios una forma de enviarme con facilidad sus opiones y sugerencias (que recordad, siempre son bienvenidas), pero tampoco molestar y mostrar un mensaje aún después de haberse hecho lo que el mensaje pedía.

En estos momentos ya están actualizados los requisitos en la página del plugin y las combinaciones de WP Carousel 0.5 con versiones de WordPress anteriores a la 3.0 están marcadas como incompatibles. La solución que yo recomiendo es actualizar a WordPress 3.0, ya que cada vez serán más los plugins que hagan uso de funciones que se han añadido en esta versión de WordPress.

Disculpad las molestias y gracias a todos por reportar los errores que habéis encontrado hasta ahora.